Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Floppy Drives in Ubuntu 9.10

  Date: Dec 04    Category: Unix / Linux / Ubuntu    Views: 406
  

I have a box of floppies I want to archive and between a mix
of the cp and dd commands I think I'll have it covered.

However, when I go to Places on the desktop I see my two
floppy drives (a 5-1/4 and a 3-1/2) but the menu doesn't
open anything. The drives will light up for a second when
I select one or the other, but nothing else happens.

I see fd0 and fd1 in /dev but it shows only root and "floppy"
group priveleges, with no user priveleges. I added myself
as a user to the "floppy" group, logged out and logged back
in again but it still doesn't work.

Both drives work fine if I access them via sudo commands
in a terminal, so the hardware is OK.

So, what's the trick to opening the floppy drives on the
desktop?

Share: 

 

6 Answers Found

 
Answer #1    Answered On: Dec 04    

Do you have to create a mount point and mount the drives
to be able to use them, in Unix that is what was required.

 
Answer #2    Answered On: Dec 04    

Well, unix has evolved considerably, via the linux branch of the family
tree. Removable media are now detected and mounted automatically upon
insertion.

The floppy access ought to just work, if root can access them then it's
a permissions issue. If you want to access them as FAT formatted
floppies, mtools is the easiest way. mformat, mcopy, and other commands
from dos with a prepended m are used for the i/o operations.

 
Answer #3    Answered On: Dec 04    

chmod doesn't seem to have any effect.

Would love to know though why the gui doesn't work. It
would be a lot faster to drag and drop than use the command
line for some of what I'd like to do.

Not that anyone uses floppies anymore but you'd think something
as basic as this ought to work. It did in Mandriva, though
that was KDE. I tried Kubuntu but samba was broken so I
stuck with gnome. I guess I have to decide what broken
features I have to live with.

 
Answer #4    Answered On: Dec 04    

Floppy is really no longer support since 8.10.
www.linuxquestions.org/.../ubuntu-8.1-wont-use-th\
e-floppy-disk-drive-681634/

 
Answer #5    Answered On: Dec 04    

I don't think that I have ever been able to get a floppy drive to work
on an Ubuntu box. Granted, the need was nil. I just have a lot of old
files on floppy disks and I've tried them at least once out of curiosity
with every distro that I've used for any amount of time.

 
Answer #6    Answered On: Dec 04    

"fd0 is not a block device"..............

 
Didn't find what you were looking for? Find more on Floppy Drives in Ubuntu 9.10 Or get search suggestion and latest updates.




Tagged: