Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

change the resolution of my monitor

  Date: Dec 03    Category: Unix / Linux / Ubuntu    Views: 515
  

I am trying to change the resolution of my monitor. It is a Dell Ultrascan P780
and I am using a Intel 82865G graphics card. I dual boot btwn Ubuntu
9.10/Windows XP Pro.

I can change the resolution with XP with no problem. When I am using Ubuntu I
only get 2 settings 800x600 or 640x480, and it says my monitor is unknown. I
want to change the settings on Ubuntu to a higher setting so I do not have to
scroll across the screen to read everything. I tried everything I could think of
and nothing.

So any and all suggestions would be welcomed.

Share: 

 

7 Answers Found

 
Answer #1    Answered On: Dec 03    

if you ever get the answer to that one let me know. I as that question 2
months ago and no one had the answer. I thought I saw some posts suggesting that
there was a problem with V.10 versus V.9. I was able to get the correct download
to install V.10 on my laptop and everything seem to work correctly except for
the resolution.

 
Answer #2    Answered On: Dec 03    

I'm no expert but here are a few things I've gleaned from reading posts
here...

There is a problem with Intel video - they haven't produced linux drivers no
released the code so others can do so. There are work-arounds, but I can't
recall what.

I'm assuming you have used the Hardware Drivers applet. There is another
utility called Envy which will semi-automate the installation of both ATI
and Nvidia video cards. It's in the repositories.

There are no easy answers to display problems, except perhaps (for desktops)
to change the video card to one that is better supported. For laptops you
are stuck with what came built in but perhaps it might be supported by
another distribution. Look into what's available from
http://distrowatch.com/ and keep trying. That's not a great answer, but this
is linux not windows. While we have an amazingly inventive community of
software engineers there are some things that haven't been fixed and may not
be for a while. After all this is free software and there have to be a few
disadvantages to that - but nothing compared to the advantages of a superior
operating system with iron-clad security.

Good luck, don't give up, keep searching and trying out every possible
alternative until you find one that works - and keep us posted. You are not
alone.

 
Answer #3    Answered On: Dec 03    

Maybe this problem is biggwer than i understand... But it seems to me that this
should be easily fixable by editing the xorg.conf file...

Putting

Modes "1200X768"

Under the screen section or device section... I dont remember which. Google
xorg.conf AND monitor resolution for examples. Its also often helpful to
search google with you specific model # and make included in the search string.

 
Answer #4    Answered On: Dec 03    

If it is a CRT Monitor. Ubuntu is slowly removing support for CRT and moving
more support for the LCD/Plasma monitors.

 
Answer #5    Answered On: Dec 03    

It is likely that you do not have the proper graphics driver installed.
Ubuntu loads a plain vanilla graphics driver if it can't find one for your
card. In Linux most graphics drivers are open source and either reverse
engineered or are supplied by cooperative OEMs. Intel is notorious for being
slow while cooperative. The problem with 9.10 was that Ubuntu used a kernel
that relies on kernel mode setting and that caused some problems because
older drivers did not work, putting pressure on OEMs t produce drivers.
(Expect similar problems with 10.04 due later this month as Ubuntu has
switched to Plymouth to handle graphical boot. And this does not work well
with many existing drivers. Change can be exciting, but mostly it is a pain
until they get things down pat.)

Your best bet it to run Hardware Drivers in System, Administration. It will
tell you if there is a proprietary driver that will improve things. The
second possibility is that the graphics driver is in place but not
activated. You can do that from Hardware Drivers as well. If this does not
work then you can manually install a driver, but that is not usually
necessary.

If you ever want to find out about your hardware open a terminal and type
lshw (for list hardware). In your case scroll back through and look for
*-display section (use scroll bar). You can highlight and copy and paste
relevant section (not whole thing) as this is sometimes useful in
troubleshooting.

 
Answer #6    Answered On: Dec 03    

I had the same problem with an Intel 82945G, and *thought* I had posted a decent
fix here. But, either my memory is faulty, or Yahoo! "Message Search" is
faulty...

Try booting with the "nomodeset" option. To do this at boot time (as a test):

Hit the letter "e" when the Grub boot menu displays. You'll get a simple editor
window.

Use the arrow keys to move the cursor to the end of the line that shows "quiet
splash". add the string "nomodeset" to the end.

Old: .....quiet splash
New: .....quiet splash nomodeset

Now, hit CTRL-X to continue your boot. You should find a greater range of
available screen resolutions when you log in.

If it works, post back here. To make it permanent, you'll have to edit a Grub
configuration file, and the process is different for Grub 1 vs. Grub 2.

 
Answer #7    Answered On: Dec 03    

I found at least 10 *different* potential solutions by doing a Google search:
800x600 ubuntuforums solved intel

Since XP is OK, I guess you can ignore the ones which suggest the cable is the
problem.

If I were you I would try this thread first:
ohioloco.ubuntuforums.org/showthread.php?t=1374212

 
Didn't find what you were looking for? Find more on change the resolution of my monitor Or get search suggestion and latest updates.




Tagged: