Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

No sound on Karmic

  Date: Dec 06    Category: Unix / Linux / Ubuntu    Views: 285
  

I had no sound after upgrading to Karmic, but then the situation got worse.
First, about no sound. I have a Creative X-Fi sound board, and had been
re-compiling the driver to obtain sound after each kernel change. Up to now, it
worked; but not after the upgrade to Karmic. (This is still under development,
and hopefully will be included in future kernels.)

I decided to restore Jaunty from backup, so that I would have sound while this
situation got resolved. This wouldn't boot, so I used the live CD to restore
GRUB, which was reported to have been restored. It still wouldn't boot.

This is a dual-boot computer. By using the GAG bootloader I was able to boot
Windows (but still not Ubuntu), and that's what I am using at this moment. For
now I would be satisfied to get Jaunty back, so perhaps someone can explain why
it doesn't boot. (Unfortunately I don't have a separate /boot partition, and it
is likely that most third-party bootloaders won't handle ext4.)

Share: 

 

8 Answers Found

 
Answer #1    Answered On: Dec 06    

Lets do some thing simple. Please go into the BIOS and disable the on board
sound device.

 
Answer #2    Answered On: Dec 06    

Please tell us what happens when you boot to Grub. Do you get an error
message or does it hang, etc.? How did you restore Jaunty from backup?

 
Answer #3    Answered On: Dec 06    

I used Clonezilla for the backup and restore operations, with a USB hard drive.
By default it tries to restore Grub, but complained in this case. I suppose I
should have written this down--the output is not saved into a file, as far as I
know.

It just hangs. Something like "stage 1.5" appears on the screen, with no further
activity.

 
Answer #4    Answered On: Dec 06    

I've just upgraded to 9.10 64-bit - found the same - no sound ...
found that there's a very difficult to see grey sound icon in the
system tray - opened it to find the slider all the way down to off -
dragged it up - hey presto! sound - simple as that ... might be worth
a look

 
Answer #5    Answered On: Dec 06    

If I were to perform a clean install, I think it would probably boot. Moreover,
I have a separate /home partition, with all user-specific stuff preserved. There
would still be some advantage to accessing the present / partition, though, so
getting it to boot somehow is the task I am concentrating on at the moment.

 
Answer #6    Answered On: Dec 06    

I was able to get back in (with GAG now used as a boot selector) by installing
Grub in the root, setup (hd1,1) in this case. So now I can work on the other
problems. This apparently shows that Clonezilla can be used with confidence to
create and restore backups, anyhow.

 
Answer #7    Answered On: Dec 06    

My Kubuntu Karmic upgrade has sound and everything works... except it
seems to log itself out if left alone for a while. I may have done
that to myself in the power saving settings. Still looking...

 
Answer #8    Answered On: Dec 06    

No sound on Karmic

G'day prof 'Tim'
-the following may complete the jagged karmic jigsaw
cheers,
dar

www.unixmen.com/.../525-resolve-nosound-problem-on-ubuntu910-\
karmic-koala

Question : I installed ubuntu9.10 and now i have , how to resolve this ?

Answer : To resolve thi issue please follow the steps bellow :

Before to start check first Your sound just might be muted. See alsamixer

Go to System -->Preferences-->Sound and check outputvolume if muted or not, if
not muted then go further with the steps bellow , if was muted ( In my case when
i installed karmic koala) then is resolved just you have to unchek mute.
First, make sure that slmodemd is not running. with this command

pgrep slmodemd

if the package installed remove with :
sudo apt-get remove sl-modem-daemon
restart your computer then go to System>Administration> Softwaresources>

In the Updates tab active "Unsupported Updates (karmic-backports), The reason
from this is to install ALSA modules backports.

Now:
sudo apt-get install linux-backports-modules-alsa-karmic-generic

Add the PPA of Ubuntu Development Team Audio and updated to download and install
their version of ALSA and PulseAudio packages.

 
Didn't find what you were looking for? Find more on No sound on Karmic Or get search suggestion and latest updates.




Tagged: