Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Karmic is toast

  Date: Dec 05    Category: Unix / Linux / Ubuntu    Views: 360
  

In over three years of using Ubuntu and living on the edge a daily update
has totalled mt Ubuntu installation. I have run alphas and this has not
happened. Basically I need to re-install Ubuntu from scratch. It won't mount
my file sytem and dumps me (sometimes) in a bash recovery shell. I have
tried to reconfigure xorg and fsck the file system. I have even tried to
edit fstab. No luck. It is often more time consuming to trouble shoot than
to do a fresh installation.

I am just giving people heads up. I did not do anything other than update.
It was the update with the latest kernel 2.6.31-16.

I am in openSuSE 11.2 now. This is one of the benefits of having multiple
distros installed.

Share: 

 

9 Answers Found

 
Answer #1    Answered On: Dec 05    

I had no problems with the kernel image update this morning.

 
Answer #2    Answered On: Dec 05    

I did not have a problem on my netbook either. But it is curious since I
have lived on the edge for so long without incident. In the end, it is no
big deal unless I lose data. Installing distros is second nature to me.

 
Answer #3    Answered On: Dec 05    

Back into my K/Ubuntu installation without re-installing. That was a time
saver! I used the recovery console to go through each xserver-xorg package.
One was missing (xserver-xorg-nv) and after I used apt-get to install it and
re-booted it worked fine.

I am not sure why it could not mount the file system as it is working, too.
Strange things have been happening. Let's hope the trend does not continue.

The first alpha of Lucid comes out on Thursday, if you have a spare
partition or want to run it in a VM. It seems that we need more testers from
alpha to final to silence the critics that came out of the woodwork against
Karmic.

 
Answer #4    Answered On: Dec 05    

That kernel appears to be completely stable on my 32-bit system.

 
Answer #5    Answered On: Dec 05    

Thanks for all of the replies. I have it fixed. It was not the kernel
itself, but something went awry with the update and a crucial package was
left out after the update. The kernel update necessitated a graphics driver
update and this is where it messed my system up. The package was
xserver-xorg-nv. I am not sure why it happened, but am glad to be back in
business. There were other errors to the file system, but they could have
been created after I did a hard boot when things hung on the first re-boot.
Funny the way one small thing can cause major problems.

 
Answer #6    Answered On: Dec 05    

Interesting. "NV" sounds like it might be nVidia. My 32-bit Karmic system has
an ATI video card, and does not have that file. My 64-bit Jaunty system has an
nVidia video card, and also does not have that file.

 
Answer #7    Answered On: Dec 05    

Yes it is. It is one of several packages that you get when you install the
Nvidia driver. For some reason the kernel update required a graphics driver
update, but did not install all of the packages. I am not sure if it was a
bad script that they have since fixed or it is something that happened due
to an interruption, etc. If the process was interrupted, it wasn't something
that I could detect. I did not have to do a dpkg fix to complete the
installation process.

In any event, if it ever happens to you, you have to work from the
commandline to fix it, using apt-get. If you don't get it right then you can
compound your difficulties with doing a hard boot. Then you get two sorts of
errors. The file system could not mount due to a problem with my swap
partition, that I still have not got around to fixing. Fsck could not fix
it, so I had to edit it out of fstab to bypass the file system check on the
swap partition and the subsequent failure. Once I solved that then I could
boot into the recovery console to fix the graphics issue.

Next I will fix fstab and see if the swap partition is working. Running
K/Ubuntu without a swap drive is not a problem. It actually seems faster. I
have 3 GBs of RAM.

Isn't Linux fun?

 
Answer #8    Answered On: Dec 05    

Could you use Gparted from a Live CD to delete the partition and re-create it?

 
Answer #9    Answered On: Dec 05    

That's my thinking. I don't have to use the Live CD as it is not mounted. I
just have not got around to it yet.

 
Didn't find what you were looking for? Find more on Karmic is toast Or get search suggestion and latest updates.




Tagged: