MS Office Forum

Ask Question   UnAnswered
Home » Forum » MS Office       RSS Feeds

cells containing formula that refer to user-defined VBA function

  Asked By: Lamberta    Date: Sep 02    Category: MS Office    Views: 1788

I've got a weird one here folks. I have a simple workbook that
keeps track of certain files on the computer by recording the
location of the file, and the date and time the file was last
modified. I have a VBA function in a cell that determines the
correct modification date of the file by using the data in 2 other
cells (PATH and FILENAME) respectively. Works great in the original
column. Yet, when I try to copy the working cell from one column to
another, the results of the formula(function) do not appear in the
target cell. The formula appears, but it will not calculate and
display the result. I've tried many things to fix this:

1. recalculate all formulas
2. check to ensure that target column/cell is not locked
3. save workbook, close and reopen
4. type formula with VBA and source cell references by hand
5. I forget what else.

Using Excel in Office 2003. Any ideas?



3 Answers Found

Answer #1    Answered By: Liam Bouchard     Answered On: Sep 02

Could you post the code for your function  so we could try to help?

Answer #2    Answered By: Hababah Younis     Answered On: Sep 02

Please consider this issue as resolved. I spoke with Microsoft tech
support. They indicated the reason the target  columns would not
display the results  of the formula  was due to the format of the
cells in the column  being Text instead of General. To fix  this, I
had to:

1. copy  the formula from the source  cell/column to the target

2. select the target cell  column, change format to General

3. select the text of the formula in the cell and press F2 then

The results of the formula then appeared as expected. I've worked
with excel  since 1999, have done extensive formula and VBA work and
have never seen this before. I was unable to find any reference to
behavior of this kind on the 'net.

Answer #3    Answered By: Ava Campbell     Answered On: Sep 02

Sounds as though the cell  has "text" format set for it. Reset the format,
then edit and save  the formula. Might work.