Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

WiFi Network Issue: ASUS WL-138g Network Adapter Card Not Found

  Date: Jan 21    Category: Unix / Linux / Ubuntu    Views: 583
  

While not exactly a computer newbie here, having successfully set up both my
laptop and a couple of other desktop dual boot PC's with Windows/Ubuntu, I must
admit being stumped by this particular problem:

My son has an older desktop PC currently still running MS Windows 2000, with an
AMD Athlon CPU, 1/2 Gig RAM, along with an Ubuntu 10.04.1 partition loaded and
running, using the GRUB boot menu. All devices are working fine, EXCEPT for the
WiFi Network Card, which simply cannot be made to work thus far. Have located
Windows Device Drivers for this ASUS 802.11, WL-138g Network Adapter Card, and
to keep this post short, have tried every one of my own limited number of Linux
`tricks' to make it function… but so far, all efforts are in vain.

Have attempted to install and use Ndiswrapper, along with the original ASUS
WL-138g Network Drivers, but clearly… I just don't know what I'm doing here.
While all other similar Ubuntu installs quickly configured network drivers, and
thus allowed me to download any needed packets and system updates, without
internet access available on this machine, I've reached a dead end.

I know Ubuntu functions much better on this machine than his old version of
Windows, but as he uses this computer almost exclusively for web surfing, he
isn't interested in even trying Ubuntu unless I can get the internet working. Is
there anyone in this group who can point the way to our success? I have a
functional USB Memory Stick for moving files around, and can use the Terminal to
input `step-by-step' command-line instructions if needed, but still need some
brainy Ubuntu/Linux Guru type to help guide the way…

Share: 

 

4 Answers Found

 
Answer #1    Answered On: Jan 21    

There is a GUI for ndiswrapper that makes it dead simple. It is called
ndisgtk and it is in the repositories. Aside form getting the right driver
you need to set up a network connection or you still won't be able to
connect. You do that from the network manager.

 
Answer #2    Answered On: Jan 21    

Is there some reason you can't use a wired connection? Since it is a desktop
computer it either has a network card or one could be picked up for about
$10. A wired interface almost always "just works" while, as you have found,
some wireless connections are quite tricky.

 
Answer #3    Answered On: Jan 21    


The WL-138g is yet another of the Broadcom chipset wireless cards that
cause so much hassle still. Have you tried connecting via cable to the
router and checking for Hardware Drivers and also getting all current
Ubuntu updates ? The few times I've come across Broadcom wireless
recently I've found this has all that's been needed.

It might even be worth investigating changing the Wi-Fi card for one
that *is* Ubuntu friendly - they aren't exactly expensive these days
and can save a lot of hassle / hair loss Depends on how easy
this ASUS is in regard to access to the card !!

 
Answer #4    Answered On: Jan 21    

This thread is very old, but it might help:
ubuntuforums.org/showthread.php

It might be useful to tell us exactly what unit this is. In Accessories/terminal
run the command: lspci
Then cope/paste the line which includes "802"
(That assumes the wireless adapter is a PCI device. If it's USB, use lsusb.)

Some wireless adapters have changed drastically from ver 2 to ver 3, for
example, and even though the packaging is the same, getting them working is
completely different.

 




Tagged: