Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

network hardware problem

  Date: Dec 05    Category: Unix / Linux / Ubuntu    Views: 317
  

My dad called day before yesterday and said he couldn't get online.
When he puts his cursor over the network icon (9.04) it says no network
connection. Right clicking on network icon choosing Connection
Information it says Auto eth0 --- never.

Tried:
sudo /etc/init.d networking restart
sudo ifup eth0
sudo dhclient eth0

Tried switching out the cable but that didn't help.

Got on the phone with support (manufacturer support) and after walking
through the usual tests they want to do, they concluded (partically)
that its not the hardware because we can ping the loopback address.

Is there anything else I can do to check the hardware? Something that I
can do to get something on the screen so I can email it to support?
(Note: the computer is about 400 miles from me so Im not have hands on.)

Share: 

 

8 Answers Found

 
Answer #1    Answered On: Dec 05    

What's the rest of his network look like? Have diags been run on whatever it is
that his PC connects to? Do the LEDs on his network port light up? What about
the other end of the cable? It could be that his modem/switch/hub is in needs
of a power cycle, or it could be dead. Has the ISP been called?

 
Answer #2    Answered On: Dec 05    

Cable modem to pc. Thats is.
Cable modem works fine with the laptop connected via cable.
I've logged in to the modem from here just fine and it is handing out ip's.

Cable company remotely powered the modem.
I had my dad do the same before that.

 
Answer #3    Answered On: Dec 05    

I disagree that being able to ping the loopback address means the
hardware is good.
I really don't agree that the loopback address is tied to the hardware
itself.
Can you dad right click on the network icon and edit the connection,
then set it to automatic and reboot?
This might make it come to life.

 
Answer #4    Answered On: Dec 05    

I do as well. I dont think it is good. I think something happened.

Right click on Network Connection, Connection Information is not
clickable. Click Edit Connection and it is already automatic.

 
Answer #5    Answered On: Dec 05    

Sounds like the network card is bad.

 
Answer #6    Answered On: Dec 05    

I disagree, I have tried 9.04 and had the very same type of failures.
Reverted to 8.10 Ubuntu and worked every time. My experience with
9.04 with networking on wire connection was very intermittant.
I could have spent a lot of time trouble shooting I suppose but again it
takes time and I just chose to revert back. I am now looking at installing
9.10, but may just reload XP and make a dual boot system with what ever
I choose for my next Linux adventure.

 
Answer #7    Answered On: Dec 05    

I called a friend to see about swapping the HD that had xp on it.
Same problem.

Im going to RMA the system.

 
Answer #8    Answered On: Dec 05    

In 9.04 what usually worked for me was the following sequence (aside from
power-down followed by power-up of my FiOS router before these steps):
sudo /etc/init.d/NetworkManager stop
sudo /etc/init.d/networking stop
sudo /etc/init.d/networking restart
sudo /etc/init.d/NetworkManager restart

If that does not work, then try deleting the file:
/var/lib/dhcp3/dhclient-da93150a-*-eth0.lease
and then retry the above steps.

Note: In Ubuntu 9.10 only the networking steps work and the NetworkManager step
does not in the above sequence because it has been changed to an upstart job
(which I have yet to figure out). However, by using the networking steps
coupled with the sudo ifup eth0 - that appeared to work for me in Ubuntu 9.10
(maybe by deleting the lease file as mentioned above).

 
Didn't find what you were looking for? Find more on network hardware problem Or get search suggestion and latest updates.




Tagged: