Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

ubuntu startup script problem

  Date: Dec 04    Category: Unix / Linux / Ubuntu    Views: 353
  

I am trying to get a script to automatically run after ubuntu ver 9.1 boots up.
I placed the script (zip.sh) in the init.d directory and made it executable
after runing update-rc.d zip.sh . Nothing works although i can get the script
to work after bootup with the command ./zip.sh. Can anyone tell what i am doing
wrong?

Share: 

 

5 Answers Found

 
Answer #1    Answered On: Dec 04    

tryed putting it in the startup applications under system preferences?

 
Answer #2    Answered On: Dec 04    

Put the reference to your script in /etc/rc.local

 
Answer #3    Answered On: Dec 04    

Tried that and it does not work. If i run the command ./rc.local the
scripts run and produce the correct results.

 
Answer #4    Answered On: Dec 04    

Make sure everything you reference is via full pathname. Startup
scripts run as root but the $PATH may not be set. If that fails, maybe
you can post your rc.local

 
Answer #5    Answered On: Dec 04    

Here is my rc.local file contents

#!/bin/sh -e

/sbin/modprobe /etc/modprobe.d/parport_pc io=0xec00,0xdd00 irq=15

/usr/bin/service cups start

exit 0

 
Didn't find what you were looking for? Find more on ubuntu startup script problem Or get search suggestion and latest updates.




Tagged: