Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

How to delete locked files?

  Date: Dec 04    Category: Unix / Linux / Ubuntu    Views: 628
  

I know, I know, this is a dumb question but search as I have, I have not found
the answer or at least one that works for me.

I have created a directory
/tmp/tmnp
and placed several files in it and mounted a CD in it. Now I need to do away
with the directory and all its contains? I have access to both myself and the
root admin. They are locked and read-only with root the owner.

Share: 

 

7 Answers Found

 
Answer #1    Answered On: Dec 04    

cd to /tmp
sudo rm -r tmnp............

 
Answer #2    Answered On: Dec 04    

I don't know what happened. Last night I must have spent an hour or so
trying to get rid of the little sucker. Could not get deleted.

Today, after Wade's reply I went there and the directory is gone. Don't have
the foggiest idea how that happened.

Ya, know. The more I think I understand about computers and Ubuntu in
particular the less I discover I actually know. Gee . . .

Oh, I sure I tried that last night and it didn't work. But before I was
going to say "I tried that" I would give it a try for sure. Anyway . . .

 
Answer #3    Answered On: Dec 04    

another option, if you are more comfortable with GUI, is to hit alt-F2
then type in "sudo nautilus" with the run in terminal option checked.

be sure to exit the program with root privileges when don or one can
mess things up easily.

 
Answer #4    Answered On: Dec 04    

First unmount the cd drive though........

 
Answer #5    Answered On: Dec 04    

I have a netbook and last night after turning off the computer I unplugged
the external USB CD. May be that helped undo things

 
Answer #6    Answered On: Dec 04    

cd
sudo eject cd
sudo rm -rf /tmp/tmnp

 
Answer #7    Answered On: Dec 04    

did you give it several restarts last night?

 
Didn't find what you were looking for? Find more on How to delete locked files? Or get search suggestion and latest updates.




Tagged: