Logo 
Search:

Java Forum

Ask Question   UnAnswered
Home » Forum » Java       RSS Feeds

axis/java : setting classpaths

  Asked By: Ruben    Date: Oct 14    Category: Java    Views: 1347
  

I am trying to use the classpath to reach code inside
axis directory. I get the following error message:

///////////////////////
C:\Program Files\Apache Software Foundation\Tomcat5.5\webapps\axis>
javac -classpath %AXIS_HOME%\lib\axis.jar SOAPMonitorApplet.java
javac: invalid flag: Files\Apache
Usage: javac <options> <source files>
where possible options include:
///////////////////////

The juxt of it is: javac: invalid flag: Files\Apache

I believe that I have the class path set correctly:
///////////////////////
C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\axis>
echo %AXIS_HOME%
C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\axis
///////////////////////

When I go ahead and set the class path relative to my current
directory, I am fine.
///////////////////////
C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\axis>
javac -classpath WEB-INF\lib\axis.jar SOAPMonitorApplet.java
///////////////////////

C:\Program Files\Apache Software Foundation\Tomcat 5.5\webapps\axis>

So, what am I doing wrong with respect to setting my class paths?
(At least I am assuming it is me...)

Share: 

 

1 Answer Found

 
Answer #1    Answered By: Doyle Gonzalez     Answered On: Oct 14

it's not your fault but MS Windows console as your %axis_home% path
contains "space" in the path  string, Windows console assumes that ur
sending
an option to javac.exe command so incorrectly executes the command.
To overcome this try:
javac -classpath  "%AXIS_HOME%\lib\axis.jar" SOAPMonitorApplet.java
as easy as this

 
Didn't find what you were looking for? Find more on axis/java : setting classpaths Or get search suggestion and latest updates.




Tagged: