Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

file system permissions for remote hard drive

  Date: Dec 13    Category: Unix / Linux / Ubuntu    Views: 584
  

I have just formatted [using System--Administration--Partition editor]
a remote hard drive for personal data. Until now i have used fat32 but
gather it is better to use ext3 to take advantage of journaling for
recovering data if it ever crashed.

The hard drive doesn't allow permission to copy files to it. Reading a
book i understood that i've got to change permissions with chmod? I
mounted the disk and in terminal did sudo chmod a+rw /dev/sdg

Well it didn't seem to work! Is ext3 that much of an advantage?

Share: 

 

12 Answers Found

 
Answer #1    Answered On: Dec 13    

It looks to me like you are changing the permission on the device
file, not the filessystem on it. Using a terminal, here is the
difference on an external USB drive that I have hooked up at the
moment:

jbuchana@zaphod$ mount | grep sdb
/dev/sdb1 on /media/disk type ext3 (rw,nosuid,nodev,uhelper=hal)
jbuchana@zaphod$ ls -ld /media/disk
drwxr-xr-x 15 root root 4096 2008-11-06 23:50 /media/disk
jbuchana@zaphod$ ls -l /dev/sdb
brw-rw---- 1 root disk 8, 16 2008-12-25 16:22 /dev/sdb
jbuchana@zaphod$

I found the mount point of the disk (which I already know, and you
likely do on your system too) with the 'mount' and 'grep' commands,
then I used 'ls' with the 'l' (long listing) and 'd' (directory
information, as opposed to what's in the directory) I then looked at
the device file for good measure, using the 'ls' command again, long
listing.

We don't have r/w permission to the device itself, but we do have
permission for the mounted filesystem. If we didn't have permission to
access the filesystem, I'd do 'sudo chmod -R 777 /media/disk', setting
the permission to rwxrwxrwx, assuming I wanted everyone to be able to
read/write to it. In my example above, only root has permission to
write to this filesystem as I have it now.

> Well it didn't seem to work! Is ext3 that much of an advantage?

That depends. If you are *only* going to use the drive on the Linux
system, yes, I'd say that ext3 is worth it. If you are going to share
with a Windows machine (which I do with my wife's laptop for the above
disk), then you'll need a filesystem that Windows can read.

 
Answer #2    Answered On: Dec 13    

Many thanks think i'm on the right road now. I had permission to mount
but not r/w makes sense now.

On the filesystem point - which should one use NTFS or FAT32. NTFS is
blanked out in the Partition editor on ubuntu 8.04 but i remember
reading somewhere that one can format to NTFS using the command line.
As i understand FAT32 is simpler but restricts file size?

 
Answer #3    Answered On: Dec 13    

Interesting, I know my son uses NTFS on a RedHat derivative (Centos),
but I see that 8.10 does not have a command line option to make an
NTFS filesystem.

Here are the options I see:

jbuchana@zaphod$ mkfs.
mkfs.bfs mkfs.ext2 mkfs.ext4 mkfs.minix mkfs.reiserfs
mkfs.cramfs mkfs.ext3 mkfs.ext4dev mkfs.msdos mkfs.vfat
jbuchana@zaphod$ mkfs.

( I found those by typing "mkfs." and then hitting tab)

Maybe he formatted and made the filesystem on a Window machine, I know
he shares the drive with one.

I'll ask him at some point, but I'm going to be out of town tomorrow,
with maybe free wireless in the hotel in the evening...

 
Answer #4    Answered On: Dec 13    


Interesting... still further! I'm reading the "beginning Ubuntu Linux
- from novice to professional" by Keir Thomas. P234 there is a note:
"You can only read from NTFS drives under linux because writing to
them is considered too risky and might result in data loss. However,
you can read and write to FAT32 partitions because of the simpler
technology used."

It would seem one can mount an NTFS filesystem from what it says on
the commandline. But that book edition was in ver 6.06/6.10 days.
Perhaps due to data loss complaints ubuntu development team decided to
leave it out in ver 8.04/8.10. I tried fedora, Suse, Mepis but always
preferred ubuntu [kubuntu i didn't like too many glitches] - haven't
tried any other distros for a while.

For practical use [i.e. being able to use a remote drive on linux,
windows home and work] it seems best to stick with FAT32. There is
http://www.fs-driver.org/ so that one can use ext2/ext3 on a home
windows machine.

 
Answer #5    Answered On: Dec 13    

The good news is that our fast developing Operating System now does fully
and safely support NTFS. I think that became true about 2 years ago, so even
slightly older books will caution you not to use NTFS. If a book wasn't
published within the last 12 months don't take it as authoritative any more!

One can format to NTFS using Gparted, available in the Ubuntu repositories.
For more information see http://gparted.sourceforge.net/features.php

I mainly use ext3 by preference because I'm convinced it is better designed,
but I have used NTFS and it worked fine for both reading and writing. It's
good to be cautious, but it's even better to be up to date...

 
Answer #6    Answered On: Dec 13    

experience Ubuntu can read and write
to NTFS but with some of the programs run under Linux there seems to be
a problem. It could be me but I have been trying to get some of the
photo programs to scan my NTFS partitions without success. I have these
partitions as my computer is dual boot and I have photographs on the
NTFS partition from my Windows days. If I go to the partition directly
from Ubuntu I get asked for my root password and then I can do anything
on the partition. When trying to see these NTFS partitions from say
Digikam or Fspot it can't be done. I guess the problem is with me but it
is frustrating. Just my 2c experience.

 
Answer #7    Answered On: Dec 13    

Try going to a terminal and typing sudo nautilus. Then use nautilus to open
Digikam or Fspot.

 
Answer #8    Answered On: Dec 13    

I get
"command not found"
Should I do apt-get install nautilus first?

 
Answer #9    Answered On: Dec 13    

which flavour of *buntu are you using?

 
Answer #10    Answered On: Dec 13    

Nautilus is the default file manager for Ubuntu and it's installed by
default, so you should have it already. The title bar probably says "File
Manager".

If you do a "sudo apt-get install nautilus" (without the quotes) it will
tell you if it's already installed. Could there have been a typo when you
tried the command?

 
Answer #11    Answered On: Dec 13    

I didn't (don't) have nautilus installed as I use KDE, but
your tip works with Dolphin as well

 
Answer #12    Answered On: Dec 13    

I assumed you used Gnome on Ubuntu. I'm glad you found
the solution to your problem.

 
Didn't find what you were looking for? Find more on file system permissions for remote hard drive Or get search suggestion and latest updates.




Tagged: