Asp.net Forum

Ask Question   UnAnswered
Home » Forum » Asp.net       RSS Feeds


  Asked By: Jason    Date: Jul 14    Category: Asp.net    Views: 842

When I have a page error, I get this message (bottom - or see page)

My web.config has the exact code as the error message. I get this
error even if I run on my server.

This is a virtual server, can that be the problem? I have working
some working .aspx pages.

How can I solve this issue so I can debug problem code?

ERROR MESAGE -------------------------------

Server Error in '/' Application.

Runtime Error
Description: An application error occurred on the server. The current
custom error settings for this application prevent the details of the
application error from being viewed remotely (for security reasons).
It could, however, be viewed by browsers running on the local server

Details: To enable the details of this specific error message to be
viewable on remote machines, please create a <customErrors> tag
within a "web.config" configuration file located in the root
directory of the current web application. This <customErrors> tag
should then have its "mode" attribute set to "Off".

<!-- Web.Config Configuration File -->

<customErrors mode="Off"/>

Notes: The current error page you are seeing can be replaced by a
custom error page by modifying the "defaultRedirect" attribute of the
application's <customErrors> configuration tag to point to a custom
error page URL.

<!-- Web.Config Configuration File -->

<customErrors mode="RemoteOnly"



2 Answers Found

Answer #1    Answered By: Adalwine Fischer     Answered On: Jul 14

You should open your web.config file  and make this change:
<customErrors mode="Off" />

Instead or RemoteOnly you need Off.
You will then get a detailed error
message which you can then debug>

Answer #2    Answered By: Kristin Johnston     Answered On: Jul 14

Don't know, all I can say is that when I must have had some problem  at some time
at here what my web  config looks like::

Set mode="on" or "remoteonly" to enable  custom error messages, "off"
to disable. Add
<error> tags for each of the errors  you want to handle. -->
<customErrors defaultRedirect="genericerror.htm" mode="RemoteOnly">
<!-- using mode="RemoteOnly" dishes out its own stuff -->
<error statusCode="404"
<error statusCode="500"

Try it , see what happens ?

Didn't find what you were looking for? Find more on Errors Or get search suggestion and latest updates.