Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Loss of desktop control

  Date: Nov 26    Category: Unix / Linux / Ubuntu    Views: 427
  

Yesterday I started noticing problems clicking on anything on my desktop. I
thought it was my mouse needing a new battery. Today, I have had to restart my
computer four times just to get some ability to click on it. Its not the mouse
as I plugged in my old stand by usb mouse. I cant click on the logs to see
anything wrong at the moment -- I cant click on anything at all.

Share: 

 

29 Answers Found

 
Answer #1    Answered On: Nov 26    

Suggestions: boot into recovery mode and/ or using a live CD. If the problem
persists it's probably hardware related.
Which ubuntu version are you using?

 
Answer #2    Answered On: Nov 26    

Im using 10.04

Ill try recovery mode and post back.

 
Answer #3    Answered On: Nov 26    

I choose low res graphics and started up.
I immediately received the error: loading "OAFIID:GNOME_PANEL_TrashApplet". I
had the same thing happened yesterday morning with the clock applet.

I can click on things now it seems.
In the system logs, under messages I see

wadesmart kernel ... radeon 0000:01:00.0: VGA-1: EDID invalid.

Under syslog there is a lot of
gdm-binary: WARNING: Unable to load file, find users, and session warnings.

Anything specifically to be looking for?

 
Answer #4    Answered On: Nov 26    

At this point I've reached the limit of my ability to "fix" ubuntu. If
it were my computer I'd be thinking about a re-install, hopefully
preserving the contents of the separate home partition.

Perhaps some of the other, more advanced, members can give you some help...

 
Answer #5    Answered On: Nov 26    

I was pointed to a link in launchpad that shows a problem with the xorg file
but, its for maverick.
Its something to do with the desktop.

 
Answer #6    Answered On: Nov 26    

Sounds like the same trouble that I am having. I've got it down to
where the desktop freezes, except for the mouse pointer. Previously,
even the mouse froze. I have to cold boot at that point. There is also
a huge thread in the Ubuntu forums about freezing problems with over
1,000 posts in it. http://ubuntuforums.org/showthread.php?t=1478787
I've tried 10.04 with freezing problems and 10.10 with freezing
problems. I have a Nvidia card, but as soon as I load nvidia-current I
cannot boot so am using the nouveau driver (no 3D). If you jump to the
middle of the forum thread, you will see that several people have posted
fixes, but no fix seems to work for everyone. This is a new computer
and was working fine until kernel 2.6.32-25 came out for 10.04.

 
Answer #7    Answered On: Nov 26    

Did yours just happen all of the sudden?

Same here though - just push the start button and hopefully Ill get a screen
saying to turn off. Even when I use the alt+F keep to try to shut down a
app, the File on the menu will highlight but you cant do anything other than
that as the up/down keys dont work.

 
Answer #8    Answered On: Nov 26    

Yes, it would not boot up to a login screen immediately after a kernel
update. I have managed to get 10.10 running with the nouveau driver. I
am fairly stable and will leave things this way for now.

 
Answer #9    Answered On: Nov 26    

I started back into normal desktop mode and when I open system log, nothing
else can be clicked on or moved about. I cant use the mouse to turn it off
either. I can use Alt+f and then click close from there.

I think you are right on the kern update. I think very shortly after that I
started having problems too.

 
Answer #10    Answered On: Nov 26    

That happened to me a couple times. Tried to scroll down to the end of
the log, and froze half way there. I can't use alt+f, nothing happens.
All I can do is Crtl+SysRq, then REISUB to re-boot. Or the power
button. The problem is affecting all types of hardware, processors and
video cards. 32 & 64 bit. Makes it difficult to diagnose. Trouble is
not everyone is affected. My wife's computer has virtually identical
hardware, and she is running 10.04 fully updated with no problems.

 
Answer #11    Answered On: Nov 26    

Ive booted up again and I seem to be working ok. The odd thing, if I dont
move the mouse around a lot - it seems to keep working. I have the syslog
open just watching for error messages. Ive also noticed that my screensaver
isnt coming on. Its set at 10min but its been 45min and its still not
sleeping.

I dont know how those are related at all but, its happening.

 
Answer #12    Answered On: Nov 26    

Well, I just figured that one out.
I couldnt move the syslog screen around and had to use the keyboard again
to
turn it off and then, as soon as it went off, my computer went to sleep.

But I can still move the terminal around.

 
Answer #13    Answered On: Nov 26    

The only time I've seen mouse problems causing system lockups or other
weird operation is when the mouse itself has been faulty ( e.g. cable
mouse with broken wires ) or being interfered with ( e.g. wireless
mouse with something transmitting nearby or between it and receiver,
or excessive electrical noise generating spurious signals - one very
memorable case was a PSU putting out a lot of noise on the 5V line
which caused some extremely strange symptoms, erratic and random
cursor movement plus spurious clicks opening up windows - was very
impressive to see in operation but the system was totally unusable ).

Have you tried a different mouse ? Wired if using wireless, USB if
using PS/2 or vice-versa.

 
Answer #14    Answered On: Nov 26    

It was time to do something drastic.
Purchased a new generic keyboard and mouse.
Plugged the mouse in I havent had any troubles yet.
I was using a logitech mouse which has been fine until now. (wireless)
I'll use this mouse (wired) for a bit to see if the problem happens again. I had
already swapped out the mouse but it was for another wireless mouse, a MS mouse.
I was worried it might be usb related because I dont have any of the older
ports.

 
Answer #15    Answered On: Nov 26    

Have you tried using the Janitor yet, it may find something to fix and help it
work better?

 
Answer #16    Answered On: Nov 26    

Ive been gone all day but I can in and my computer is STILL working.

Im going to hook up my wireless mouse and see if it locks up and then if it
does
switch back to this wired mouse and then I should know for sure.

 
Answer #17    Answered On: Nov 26    

Looking good that it was the mouse, or at least some sort of
interference affecting it.

Hardware faults need hardware fixes and software faults need software
fixes - the problem is finding out whether you have a software or
hardware issue in the first place

 
Answer #18    Answered On: Nov 26    

I think this underlines what's been said before about Ubuntu. If you
want stable and everyday use then stick with the LTS versions, i.e.
10.04 LTS, and leave the cutting edge alone ( or at least run on a
test machine / virtual machine ). Seem to remember reading somewhere
that the April releases tend to be less stable than the October ones.

Overall I'll stay with Lucid for my main system and may try out the
later ones in Virtual Box but possibly won't have the time to do much
with them apart from a getting a general idea how things are going
with Ubuntu.

Usually with a kernel update the start screen lists the older ones and
you have the option of booting with an earlier one - or has this been
removed from 10.10 ?

 
Answer #19    Answered On: Nov 26    

Im on 10.04. I dont like the cutting edge on my work machine.

I havent tried clicking on one of the older kerns yet.
Ill try that now.

 
Answer #20    Answered On: Nov 26    

Im having the same problem on kern 2.6.32-24.
I thought it was going well but then.... nothing moves.

 
Answer #21    Answered On: Nov 26    

Looks like it's not the kernel then but try the re-configure when
booted into the 2.6.32-24 kernel and see if that helps.

Also worth opening up Synaptic Package Manager and checking for broken
packages / repairing.

 
Answer #22    Answered On: Nov 26    

Checked for broken packages and there are none.
You mean reconfigure xorg? Or the kernel?

 
Answer #23    Answered On: Nov 26    

My experience is just the opposite. With 10.04, I had occasional total lockups,
especially when the computer is cold. 10.10 has been rock solid, has not locked
up once in three weeks of constant use.

My CPU is an AMD Phenom II, which is fully supported by the kernel which ships
with Maverick. Previous versions couldn't read the CPU temperature.

 
Answer #24    Answered On: Nov 26    

There's a well know acronym in computing - YMMV ( Your Mileage May
Vary ) and if there's one thing we can be sure of it's that we will
not all have the same experience of virtually any program or piece of
hardware. Great that you found 10.10 to be more stable on your system
than 10.04 - others find the reverse ....

 
Answer #25    Answered On: Nov 26    

I have an Nvidia card. I ran both Lucid and Maverick without a problem,
using the current driver. i have done all of the upgrades including the
kernel. While it may be convenient to attribute it to the kernel or driver
or Maverick, you should not be so hasty.

When I read the link posts, I see the same sort of finger pointing. It
worked in Karmic, blah blah.There are changes from one version to another.
From Karmic to Lucid, they moved from usplash to plymouth and that meant
changes to the driver and there were problems for Nvidia users in
particular. That is why there were over 1000 posts. Karmic drivers would not
work and it is pointless to look back at solutions that worked in Karmic. So
you are comparing apples to oranges. Different drivers, different situation.


The move to Maverick from Lucid is not the same. There was no change in
drivers or boot loading. Ergo, there should not be the same level of
problems. The long and the short of this is that you cannot compare between
releases and look at forums that deal Karmic or Lucid when you are using
Maverick. Each version has its own set of problems. By looking back to past
versions you are only adding confusion.

If there are problems, and I am not doubting you in this, it likely has to
do with the wrong driver because as I said, mine works fine. Incidentally
did you upgrade or do a fresh installation?

The kernel upgrade could affect the driver. You may need to re-install the
driver and re-compile the kernel module to go with that kernel depending on
the driver and how you installed it. When there is a problem with the
driver, Ubuntu defaults to a plain vanilla solution and uses the Nouveau
driver which as you say has no 3D. BTW, I have full 3D effects, so don't
give up.

 
Answer #26    Answered On: Nov 26    

Im running Lucid not Maverick.

My video card is a RV740 Pro [Radeon HD 4650].

When I moved from 9.04 to 10.04 I did a fresh install, and the video has worked
perfectly until now.

Im not running any desktop effects.

Im not using any proprietary drivers.. just did a fresh install of 10.04 and its
been working.

Someone suggested selecting the previous entry in the list, 2.6.32-24 when
booting, which I did, but had the same problems there.

 
Answer #27    Answered On: Nov 26    

I did a fresh install of 10.10 64 bit. It booted up fine with the
nouveau driver. I installed the Nvidia driver from
System/Admin/Additional Drivers. When I re-booted, the Ubuntu screen
with the red dots below Ubuntu appeared, then my monitor displayed No
Signal. The computer fan was still going, but nothing else happened.
So I did another fresh install of 10.10 and left the nouveau driver. I
don't know how to re-compile the kernel module. If I cannot boot after
I install the Nvidia driver, what should I do? My card is an Nvidia 220
GTS. I am using kernel 2.6.35-22-generic. I re-loaded synaptic, but it
did not find anything broken or needing repair.

 
Answer #28    Answered On: Nov 26    

Actually you do not compile the kernel module. Nothing is required on your
part. It just happens when you change drivers. Ubuntu uses dkms which should
silently take care of any changes that you make. However, you can mess
things up if you change from the default kernel and changes to the driver
may not work with an older kernel and vice versa.

I have had this happen on Ubuntu in the past year. I update the kernel and
it works fine. If I try to boot a previous kernel which shows in grub, the
graphics go back to plain vanilla. It sounds like the reverse is happening
here and for some reason the new kerenl is not working with the driver.
Switching to a previous kernel from grub may restore things. It is not a
permanent solution because you want to use the latest kernel. This is the
main reason why kernels do not get many upgrades with a version and do not
go beyond patching the existing kernel to fix a vulnerability and the like.

 
Answer #29    Answered On: Nov 26    

Im using 2.6.32-25 right now.

 
Didn't find what you were looking for? Find more on Loss of desktop control Or get search suggestion and latest updates.




Tagged: