Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Browser is NOT Java enabled & not being able to update to FF 3.5

  Date: Dec 07    Category: Unix / Linux / Ubuntu    Views: 1270
  

I'm lost as to what to do to get my browser Java enabled. I've gone to Firefox
Preferences/ Content/ and checked Enable Java. I even Enabled Java Script with
all 5 boxes checked in "advanced" option. Still I go to a site that saids my
browser is not Java enabled.

Any suggestions?

I'm using 9.04 and up to date. Firefox is ver 3.0.13. BTW, I have the "check
for updates" grayed out. Any word on being able to update to 3.5?

Share: 

 

6 Answers Found

 
Answer #1    Answered On: Dec 07    

Java and java script are quite different. You need to open synaptic and look
for jre and the plugin, I use the sun-java plugins but you can go for iced-tea
as well.

 
Answer #2    Answered On: Dec 07    

For having it work, it's necessary to have in the plugin directory
of your prowser a symbolic link to a file which name would be
libjavaplugin_oji.so
Personnally I had troubles and fought a lot for getting out of it.

In France we have (and I suppose it also exist in a lot of countries)
a secure system fo credit card payments, called e-CB here. Via internet
logged to a special service of your bank you create a virtual card
with legal number, ending date, control number exactly like a real
and it just works once for just one amount, and it is paid from your
real card account. But for internet payments it's very secure, since
the number is valid just once, and it's impossible to overpay, the
maximum is what you chose when creating.

Well for that system be able to work, it's mandatory to have
Java and Flashplayer working on your browser. The only way I
found was to make such symbolic link

You set your terminal in the directory where browser plugin is
example : "cd /usr/lib/firefox-3.0.13/plugins/"
Then you type your symbolic link command pointing to the
directory from which you need the symbolic link
example :
sudo ln -sf /opt/jre1.6.0_14/plugin/i386/ns7/libjavaplugin_oji.so

 
Answer #3    Answered On: Dec 07    

Have you installed the Java plug-in yet? If not, the easiest way to do that is
to open a terminal window and execute the following (after the dollar sign
prompt):

$ sudo apt-get install sun-java6-plugin<enter>

This will download the Sun Java plug-in for version 6.0, and will also create
all of the necessary symbolic links to make it work. You will need to restart
Firefox after this.

To verify the installation, open a new Firefox window (or tab) and type
"about:plugins" in the address bar. This will display your Firefox plugins.
Scroll through this window and look for the section titled "Java(TM) Plug-in
1.6.0_14".

 
Answer #4    Answered On: Dec 07    

As for upgrading to Firefox 3.5, it should already be in your repositories. To
install, open a terminal window and type in the following (after the dollar sign
prompt):

$ sudo apt-get install firefox-3.5 firefox-3.5-branding
firefox-3.5-gnome-support<enter>

If this does not help, something is not configured right on your setup of
Ubuntu.

 
Answer #5    Answered On: Dec 07    

All the Java packages are in Synaptic for easy installation. You need to
install it first.

 
Answer #6    Answered On: Dec 07    

Just a hunch: A while back, I was having trouble with one Java site, and spent
a long time on a wild goose chase. Turned out that I had to enable third-party
cookies for that particular site to work. The error message was about Java, but
my Java installation had nothing to do with it.

Do other Java-required sites work? Have you run the test at java.com ?

 




Tagged: