Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Weird problem with 3Com cards

  Date: Nov 24    Category: Unix / Linux / Ubuntu    Views: 383
  

My linux system (running SuSE 7.3) has 2 network cards.

The first is an Etherlink XL and the second is an Etherlink III Combo.
The first is a 10/100 MBit card for my internal network.
The second is a 10 Mbit card for my ADSL connection.

Before I has ADSL I loaded this driver voor the XL card
(in /etc/modules.conf)
alias eth0 3c90x

This worked fine, but I activated my Etherlink III for the ADSL
connection, So I changed my modules.conf to:
alias eth0 3c90x
alias eth1 3c509

Now the Etherlink III is suddenly eth0. :-(
I try to load the 3c90x manually, but this doesn't word.
So after a couple hours of wrestling with this I found out that the
driver 3c59x works for my XL card.
So I changed /etc/modules.conf again to this:

alias eth0 3c59x
alias eth1 3c509

But still eth0 is the Etherlink III card!
When I do rmmod and insmod manually it works.

Anyone suggestions and/or Solution for this ultra-weird problem?

Share: 

 

5 Answers Found

 
Answer #1    Answered On: Nov 24    

the aliases should be placed in your rc files before
your modules get loaded. Otherwise there's no point. Also, Look at the
rc.modules file, or whatever equivilant you have, and see that the XL
module is being loaded before the III combo. The first ethernet module
to be loaded should place that card on eth0, second on eth1 automatically.

 
Answer #2    Answered On: Nov 24    

need to reformat the redhat 8.0 to intall
win2000. i can't uninstall or use lilo. b/c it has
only grub. so i downloaded the fdisk from the web put
it in the bin and then fdisk did work. ok i deleted
all the hde partitions and chked they are all empty.
Rebooted to install the win2000 it says can't see the
hard drive. soon in 15 siconds it reboots and i get
grub> prompt. only halt works here. in cmos do i have
change something or what it could be . do appreciate
any help.

 
Answer #3    Answered On: Nov 24    

You may need to do a "Low-level format" You should be able to get one
of these apps from your HD manufactorer for dos, but sometimes they can
be a pain. A low-level format brings your harddrive essentially to the
same as when it came out of the factory. If you HD maker doesn't have
a low-level format, go to Maxtor, they do, and it doesn't matter what
brand you use.

You could also try GNU Parted. Get it from GNU here:
http://www.gnu.org/software/parted

 
Answer #4    Answered On: Nov 24    

Have you tried booting in floppy and use fdisk? say fdisk /mbr

then fdisk again to remove all the partitions.

 
Answer #5    Answered On: Nov 24    

Merely copying the command.com and command .sys won't make your systems boot n the floppy drive. In a machine with a windows 98 Os, open a DOS prompt then key in " sys A: " this will copy the boot system in drive A: if this will not work go to c:\windows\command then type " sys A: " then copy fdisk.exe from c:\windows\command to drive A: then on the machine where you installed linux, configure the BIOS to boot in Drive A: first in the boot sequence then SAVE your settings. Try then to boot, if its success then type fdisk /mbr

 
Didn't find what you were looking for? Find more on Weird problem with 3Com cards Or get search suggestion and latest updates.




Tagged: