Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

BIND 9 only knows global IP but doesn't know internal LAN IP whose private IP

  Date: Nov 24    Category: Unix / Linux / Ubuntu    Views: 1003

I have a LAN for my office. I use only one ISDN line
as the internet access for my LAN users. As the
gateway I use 1 machine. This machine (named "proxy")
has squid (as proxy server), BIND9 (as DNS server) and
SuSE Firewall 2.
As the operating is SuSE Linux 8.

Now, I want my BIND9 works not only for "caching
service" but also as DNS server for my LAN. So the
user machine can also use only name not always IP

I have re-configured "/etc/named.conf" file and
defined my domain. my zone file is

I can launch my BIND9 but it works strange. it's
ridiculous because my BIND9 only knows the IP address
from outside of my LAN but not the IP address in my
internal LAN domain (duisburg.lam-ag.de).

Looks like my BIND9 can not understand my zone
definition list. But I don't know where the mistake.

Here is my "/etc/named.conf" and
"/var/named/duisburg.lam-ag.zone" files.

Please help me. I have this problem since a couple

Thank you very much in advance.

duisburg.lam-ag.de. IN SOA proxy ifirdaus.arcor.de. (
2002091842 ; serial (d. adams)
2D ; refresh
4H ; retry
6W ; expiry
1W ) ; minimum

IN NS proxy
IN MX mail.arcor-online.net

transistor IN A
proxy IN A
ifirdaus IN A
apasenau IN A
hterporten IN A
hgetreu IN A
managers IN A
ss IN A
scrtry IN A

options {

# The directory statement defines the name server´s
# working directory

directory "/var/named";

# The forwarders record contains a list of servers to
# which queries should be forwarded. Enable this line
# modify the IP-address to your provider's name
# Up to three servers may be listed.

#forwarders {;; };
forwarders {;; };

# Enable the next entry to prefer usage of the name
# server declared in the forwarders section.

#forward first;

# The listen-on record contains a list of local
# interfaces to listen on. Optionally the port can be

# specified. Default is to listen on all interfaces
# on your system. The default port is 53.

#listen-on port 53 {; };
listen-on port 53 {;; };

# The listen-on-v6 record enables or disables
# on IPV6 interfaces. Allowed values are 'any' and
# or a list of addresses. IPv6 can only be used with
# kernel 2.4 in this release.

listen-on-v6 { any; };

# The next three statements may be needed if a
# stands between the local server and the internet.

query-source address * port 53;
transfer-source * port 53;
notify-source * port 53;

# The allow-query record contains a list of networks
# IP-addresses to accept and deny queries from. The
# default is to allow queries from all hosts.

allow-query {;; };

# If notify is set to yes (default), notify messages
# sent to other name servers when the the zone data
# changed. Instead of setting a global 'notify'
# in the 'options' section, a separate 'notify' can
# added to each zone definition.

notify no;

# The following three zone definitions don't need any
# The first one defines localhost while the second
defines the
# reverse lookup for localhost. The last zone "." is
# definition of the root name servers.

zone "localhost" in {
type master;
file "localhost.zone";

zone "0.0.127.in-addr.arpa" in {
type master;
file "127.0.0.zone";

zone "." in {
type hint;
file "root.hint";

# You can insert further zone records for your own
domains below.

zone "duisburg.lam-ag.de" in {
type master;
file "duisburg.lam-ag.zone";

zone "23.168.192.in-addr.arpa" in {
type master;
file "23.168.192.zone";



6 Answers Found

Answer #1    Answered On: Nov 24    

With that small a network, it would be easier to just setup a /etc/hosts
on all your machines. Make sure your host.conf searches locally as well
as in BIND. I could never get Bind to work with a local address either.
donno why.

Answer #2    Answered On: Nov 24    

But I need centralized IP database. Is it possible ?
My clients are windows 98/XP and linux.
I can not force my managers and director to use linux.
I tried but they were angry because they felt bothered
to use linux. They don't want to learn something new.

Answer #3    Answered On: Nov 24    

Seems like what you want to use is DHCP and BIND. Use nsswitch.conf to
configure where you look first.

Answer #4    Answered On: Nov 24    

I am still using static IP for my LAN not yet DHCP
I have not understood your solution. Please tell me
furthermore (more detail). How should I configure my
"/etc/nsswitch.conf" file ?

Here is my "/etc/nsswitch.conf" :

hosts: files dns
networks: files dns

services: files
protocols: files
rpc: files
ethers: files
netmasks: files
netgroup: files
publickey: files

bootparams: files
automount: files nis
aliases: files

Answer #5    Answered On: Nov 24    

You want to somehow
manage these boxes from a central location so-

For me the easiest way is to find out what the have in common-same town,
same department etc. Then create a subdomain and zone records for that
sub-domain-for instance: mycity.mydomain.com or mydept@....
Delegate authority if you need to and point the DNS for those boxes at the
authority for that subdomain.

Answer #6    Answered On: Nov 24    

files dns is always a good way to do it - i think