Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Annoying System Beep returns after update 8.04 to 8.10

  Date: Dec 14    Category: Unix / Linux / Ubuntu    Views: 379
  

the famous (and annoying) system speaker "beep" problem has
reared its ugly head after an update from 8.04 to 8.10 on my IBM
Netvista P4 Desktop PC w/Xubuntu.

Before the update, I had edited the file /etc/modprobe.d/blacklist to
include the line

blacklist pcspkr

(at bottom of file)

During the upgrade process, I was given a choice;-- blacklist file
(select either old or new) -

Since I edited the old file to blacklist the internal PC speaker, I
saw no reason to take the new version (thinking "why reinvent the
wheel?") but I'm now getting the system beep every time the Xubuntu
login screen appears, and whenever I shut the system down or log out....

I'm thinking somethings up with Xubuntu 8.10, or perhaps I should not
have chosen to keep the old (edited) blacklist file.

Any suggestions?

Share: 

 

4 Answers Found

 
Answer #1    Answered On: Dec 14    

Edit the new blacklist file ?..................

 
Answer #2    Answered On: Dec 14    

That's only because sounds are set in Preferences/Sounds. Go there and
change the settings.

 
Answer #3    Answered On: Dec 14    

yes, I edited the new blacklist file - I did everything from
removing the line, saving, restarting computer, then adding in
blacklist pcspkr back into the file- no change

I tried the sound preferences from "Settings Manager"=> Sound
in Xubuntu, but that control is very limited- it only brings up a
long list of sound devices that I can either "check" or "uncheck"
and I was unsure of which device name is the PC speaker, if it's there at all...

 
Answer #4    Answered On: Dec 14    

I think that there has been some confusion on here because of the
differences
between Ubuntu and Xubuntu! In Ubuntu, the option exists under
System>Preferences>Sound to disable system beeps. Having run up an
Xubuntu live cd, I see that this doesn't apply.

I'm not sure if the following will sort it out for you but it's worth a try
if you haven't already. In a terminal type "sudo xfce4-mixer". This will
bring
up a mixer. One of the sliders is PC Speaker.

 
Didn't find what you were looking for? Find more on Annoying System Beep returns after update 8.04 to 8.10 Or get search suggestion and latest updates.




Tagged: