Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

xorg.conf file missing

  Date: Dec 03    Category: Unix / Linux / Ubuntu    Views: 284
  

I am still investingating my constantly running touch pad problem. Several
solutions suggested making changes to the xorg.conf file, of course after
making a copy. Here is the kicker, I don't have a xorg.conf file in
/etc/X11.
I have several other files, so my question is how do I get the file
installed.
I have tried reinstalling two x?? packages to not have any help.
I did follow one sugestion to install gsnaptics package and when attempting
to run it I get an error saying it has to have SHM??? set in xorg.conf
to operate.
So that indeed reinforces my not having the xorg.conf file on the PC. It
would
be nice if there was tool to create on, or maybe there is a command to
do just
that, any ideas?

Share: 

 

3 Answers Found

 
Answer #1    Answered On: Dec 03    

I have one at that location, so I don't know what is happening with
you. You can reconfigure xorg with: sudo dpkg-reconfigure -phigh
xserver-xorg

 
Answer #2    Answered On: Dec 03    

OK, tried it and got some error messages.
Here is a captured contents of the directory /etc/X11

=======

marty@marty-laptop:~$ ls -l /etc/X11 > cont
marty@marty-laptop:~$ cat cont
total 72
drwxr-xr-x 2 root root 4096 2010-05-14 14:44 app-defaults
drwxr-xr-x 2 root root 4096 2010-04-29 07:27 cursors
-rw-r--r-- 1 root root 14 2010-04-29 07:28 default-display-manager
drwxr-xr-x 6 root root 4096 2010-04-29 07:25 fonts
-rw-r--r-- 1 root root 17394 2009-12-03 04:56 rgb.txt
lrwxrwxrwx 1 root root 13 2010-05-04 17:13 X -> /usr/bin/Xorg
drwxr-xr-x 3 root root 4096 2010-04-29 07:27 xinit
drwxr-xr-x 2 root root 4096 2010-04-15 07:12 xkb
-rwxr-xr-x 1 root root 709 2010-04-01 06:19 Xreset
drwxr-xr-x 2 root root 4096 2010-05-14 14:44 Xreset.d
drwxr-xr-x 2 root root 4096 2010-05-14 14:44 Xresources
-rwxr-xr-x 1 root root 3730 2010-04-01 06:07 Xsession
drwxr-xr-x 2 root root 4096 2010-05-14 14:44 Xsession.d
-rw-r--r-- 1 root root 265 2008-07-01 12:41 Xsession.options
-rw------- 1 root root 601 2010-04-29 07:20 Xwrapper.config
marty@marty-laptop:~$

==============

As I say entering the below command did nothing.
I suspect the package whatever it is, isn't completely installed.
What package can I remove and reinstall.

 
Answer #3    Answered On: Dec 03    

I think if this is a fresh install of 10.04... there is no xorg.conf file.
That's what I have been told, anyway- that everything is supposed to be
detected by default. But that if you create the file, it will be
automatically used.

 
Didn't find what you were looking for? Find more on xorg.conf file missing Or get search suggestion and latest updates.




Tagged: