Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Trying to Install Wi-Fi on Dual-Boot Acer Aspire

  Date: Dec 17    Category: Unix / Linux / Ubuntu    Views: 488
  

Here's what I've found so far:
Wi-Fi is working under Vista. I followed the menu
Vista Control Panel
Device Manger
Network Adapter
Drivers. At this point Vista presented:
Atheros AR5007EG Wireless Network Adapter
c:/windows\system32\DRIVERS\athr.sys

Restarted the Acer
In Ubuntu 8.04:
Administration
Hardware Drivers
Device Drivers. At this point Ubuntu reports:
Atheros Hardware (HAL)
Enabled is checked & In use is checked
Support for Atheros 802.11 Wireless LAN
Enabled is checked & In use is checked

Inserted 8.04 installation disk
installed ndisgtk
which also installed ndiswrapper-utils

Went Through the Menus
Applications
Accessories
Terminal
steven@steven-laptop:~$ sudo ndisgtk
entered my password
After a few seconds the window shown in Ubuntu Hacks page 156 top
appeared.
Using the path found in Vista and substituting Acer in place of c: I
browsed to athr.sys.

When I accepted athr.sys and clicked Install New Driver the window
reported not an inf file.
Searching through the driver folder I found 4 or 5 inf files. Non of
them referred to Atheros or 802.11.

Where do I go from here?

Up until two hours ago this was merely an adventure. But now my
daughter's employment takes her away from home. She needs her Wi-Fi
working to communication with her children.

Share: 

 

19 Answers Found

 
Answer #1    Answered On: Dec 17    


With an Atheros chipset, I think you would be better off avoiding
using the ndiswrapper Windows driver. Native Linux drivers should work.

Since Ubuntu 8.10 has now reached the Release Candidate stage, I would
recommend grabbing a bootable CD of 8.10 now, to see if it cures your
WiFi problems.

http://releases.ubuntu.com/

 
Answer #2    Answered On: Dec 17    

I'm using 8.04 and it still won't work.

 
Answer #3    Answered On: Dec 17    

I think I'm going to try 8.10. I'm using 8.04 without results.

 
Answer #4    Answered On: Dec 17    

I'm using a single boot setup, so it may be easier for me to load 8.10. I'm
not real confident that it will work.

The whole message that I get when I open Hardware Drivers is

Proprietary drivers do not have public code that ubuntu developers are free
to modify. They present a risk to you because they are only available on the
types of computer chosen by the manufacturer, and security updates to them
depend solely on the responsiveness of the manufacturer. Ubuntu fix or
improve these drivers.

I did get my pcm-cia wifi card to work. It is a Belkin. I had it in my old
laptop. It works fine with ubuntu.

 
Answer #5    Answered On: Dec 17    

If 8.10 doesn't fix it, you'll probably really be feeling DOWN.

Then, I would suggest booting into Puppy, as it has one of the
smartest WiFi configurations that I've seen in a Linux distro.

At least get a taste of Linux WiFi success, to cheer you up, until you
figure out how to get it working on the Big Distros.

 
Answer #6    Answered On: Dec 17    

We managed to get them working with Mandriva.

 
Answer #7    Answered On: Dec 17    

Nope. I just installed 8.10 in the machine. The hardware drivers screen
looks different, but the results are still the same.

 
Answer #8    Answered On: Dec 17    

Actually, I liked the 8.04 a little better. With my wide screen, the 1280 X
768 resolution looked good, but that size wasn't available on 8.10. Hmm,
Strange.

Other then that, it looks the same except for the background.

 
Answer #9    Answered On: Dec 17    

These Live CDs should allow you to check out WiFi without having to
waste time installing to your hard drive.

In other messages, that never showed up...I was going to suggest you
give PuppyLinux.com a try since their 4.1 version came out within the
past month. Puppy has been very good at configuring WiFi, and will at
least put you in a better mood if you can have a teeny Linux success,
before fixing the WiFi for the Big Distros.

Your particular Atheros chipset is obviously too new to be handled by
many OSes.

 
Answer #10    Answered On: Dec 17    

I scrapped vista all together. I think you don't get the full affect if you
don't install the software, so I just install them. I'm using my desktop to
write these messages.

I'll try Puppy. I've used Puppy and DSL before. The computers at work (I no
longer do that) were windows boxed and they wouldn't let us install software
on them. Puppy and DSL would install on thumb drives, so I could use them to
get my software to work there.

I don't mind trying different things. I have a fast internet connection, so
downloading ISOs doesn't take very long.

My laptop is almost a year old and the warranty is about to run out. They
told me they wouldn't cover it if it didn't have the original software in
it, so I lived with Vista.

 
Answer #11    Answered On: Dec 17    

I've been working on the same problem. I found out that the drivers that
come with ubuntu are $#!+. There is supposed to be a work around.

First I Googled 5570z wifi (I have an Aspire 5570z which also has an
ar5007eg)

I got some links to some download if madwifi. The first ones that I
downloaded were outdated. The second ones I downloaded were supposed to be
good, although all I got were errors when I tried to install them.

http://madwifi.org/

http://madwifi.org/wiki/UserDocs/FirstTimeHowTo

That is where I am now. No luck so far.

 
Answer #12    Answered On: Dec 17    

I never was able to get my Acer Aspire 5570 to work on Wifi with
Ubuntu, SUSE, or Fedora. After a week I gave up and downloaded
Mandriva 8 and then 9 and they both were so easy I just about fell
over, it asked for either the windows INF file or found a Linux
driver firmware and it just worked after setting the SSID and
Passwords. I tried 3 other USB WIFI sticks and they all just worked
either with a Linux driver or Windows as required.

I hope 8.10 can do the same smooth operation with WIFI Cards that
Mandriva can now.


I know I should be able to figure how to get it working in any of the
Linux Versions but so far I am still scratching my head to accomplish it.

 
Answer #13    Answered On: Dec 17    

I am looking at the athos web page.

http://www.atheros.com/pt/AR5007EG.htm

It doesn't appear that they offer any drivers. Not even Windows drivers.

 
Answer #14    Answered On: Dec 17    

Looks like a case of too new of a chipset to be supported by OSes.

Download the small Puppy Linux 4.1 bootable CD to see if it recognizes
it, as it came out less than a month ago.
http://puppylinux.com/

8.10 Release Candidate also might be new enough to have the right
drivers for such a bleeding-edge chipset. Blame the chipset
manufacturer, not necessarily the OS.

 
Answer #15    Answered On: Dec 17    

I downloaded Mandriva 2009 from their web
site today. I installed that and the network came up just fine.

I would like to get my blue tooth doggle to work, but I'm not going to fret
over it. I have a couple of different ones. Maybe one of them will work.

 
Answer #16    Answered On: Dec 17    

I Installed Puppy on a flash stick (yum!). But it dead-ended in the same way a
Ubuntu. It wanted a .inf driver file. Like you I found nothing at the Atheros
web site.

 
Answer #17    Answered On: Dec 17    

I've changed the Acer Aspire to dual-boot Mandriva (default) and
Vista. At least I'm now communicating with the group via GNU-Linux.

The Lenovo Laptop "wants" to take a different path. When I tried to
use Wi-Fi it didn't work. But it did suggest a Ubuntu page and items
to get from that page. I'll get those using Mandriva and try them.

I want to keep Ubuntu everywhere it works without hassles. But I also
look forward to playing with the Puppy distro 4.1 I got during this
adventure.

My granddaughter picks up viruses by the bushel. I'll put Ubuntu
(first choice) or Mandriva (second choice) on her Gateway Laptop.

 
Answer #18    Answered On: Dec 17    

Not being a commandline guy, I would install ndisgtk which gives ndiswrapper a
GUI and it takes care of the background stuff such as chmod and making the
Windows driver start when you boot the computer.

The inf file may or may not refer to your specific chip by name. However, it
should work and if it doesn't you can do it over with the GUI approach. The
commandline approach can be daunting because you need to type precisely, use the
exact syntax and must know paths which many newbies don't. That's why I would
advise people to install ndiswrapper, plus utils and the gtk GUI. Linux purists
would say, to use the commandline, but it isn't realistic for many people and it
often is more work in the end as often need help from others by searching
forums, you must be precise and it usually involves more steps. Besides, I have
a lousy memory, especially for things I use only once in a blue moon. I often
have to go to the net for help with commandline stuff, but with the GUI I can do
it in one step by only reading the onscreen prompts. For me I know what works.

With the GUI, you find the inf file and the rest is done for you.

 
Answer #19    Answered On: Dec 17    

The drivers don't come with Ubuntu. They come with the Linux kernel. Make sure
you are blaming the right people. Kernel development is separate and all distros
rely on the same kernel source, the Linux foundation under the direction of
Linus Torvalds. Kernel development is ongoing and as developers and OEMs work
together more drivers are built in. You can often improve (and in rare instance
make worse) your situation by upgrading the kernel to a newer version. The
latest kernel 2.6.x.27 is in Intrepid Ibex and on many other recent distros such
as SimplyMEPIS 8 and Fedora 10.

You can check your kernel version with the terminal command: uname -r

Ubuntu 8.04 is running 2.6.x.21 or thereabouts. You can have multiple kernels
installed and from grub you can choose an older one if you choose. You can
install a newer kernel or build your own depending on your ability and interest.

The biggest problem with wifi and graphics is not Linux. It is with OEMs and
their slow adoption of the Linux platform. Those of us who have been around for
awhile have seen an exponential improvement lately, so just be patient and
drivers will come. Linux is not alone in this. Vista has a driver shortage as
well and M$ works closely with OEMs. In this case OEMs may be reluctant to
supply drivers for older equipment in Vista hoping to sell users new hardware.
There is no shortage of Vista drivers for the latest and greatest. With Linux it
is often the opposite. Better support for the older and less support for the
newer.

If you have your Windows driver CD you can use ndiswrapper. Make sure to install
three packages, ndiswrapper, the utils and the GUI, gtkndis. It isn't the ideal
situation, but it works.

 
Didn't find what you were looking for? Find more on Trying to Install Wi-Fi on Dual-Boot Acer Aspire Or get search suggestion and latest updates.




Tagged: