Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Still no print

  Date: Nov 30    Category: Unix / Linux / Ubuntu    Views: 347
  

I have been looking for a solution to my no print capability in 10.04
on the Ubuntu forum and some other places. There was a suggestion
to load or reload cups which I did, but it didn't help. Then there was a
suggestion to bring up the menu configuration editor and select print,
which isn't listed. So I must have somehow removed the whole print
feature. What could it be that I removed? Any ideas of what I removed
by mistake?

Share: 

 

20 Answers Found

 
Answer #1    Answered On: Nov 30    

Interesting this, as whenever I try to print, the printer (HP930C)
goes through all the motions, but only throws out a blank page. It's
ok on my mate's Windows box, however.

 
Answer #2    Answered On: Nov 30    

I have my pc set to dual boot and windows works fine. My Ubuntu
used to work and I had it setup to print on my network, but I must have
removed something or things and caused the print sections of the system
administration to go away. When I try to print something, the only printer
available is print to file, which works, but then I don't see my
printers that
were configurered before. I did do a reinstall of Samba and cups also. Still
not in system administration.
Help that I have found says that to configure the printer to use system
administration then select printer then use the find printer using samba.

 
Answer #3    Answered On: Nov 30    

try this

https://wiki.ubuntu.com/HardwareSupport

The 4 R's Rebuild, Recycle,Redesign and Reuse can't bury it for ever

 
Answer #4    Answered On: Nov 30    

You coulod have a look there http://www.turboprint.info/
I could not print any more after having upgraded to 10.04 Lucid Lynx, tried many
recipes found on various forum but nothing worked, then I tried this Turboprint
software (free use during 30 days to test it then you have to pay if you are
satisfied and want to continue).
I was satisfied as I have now nearly all the capabilities found on Windows XP
for my Canon iP90 printer, I bought the licence.

 
Answer #5    Answered On: Nov 30    

There isn't much helpful information here that makes troubleshooting easy.

 
Answer #6    Answered On: Nov 30    

I know, it is obvious that I have removed the print setup feature from
the System/Administration somehow. If I look in Preferences and Main
Menu I don't see it listed under System/Administration either, so if it
were there and just not ticked, I could probably get it back. But since
it isn't even listed there makes me believe I have removed something
I shouldn't have. I think I am going to copy all my home files to my flash
drive and reload 10.04 and start over. There is something else I want to
do anyway. I have a separate partition I had planned on having my home
folder. This will get these two separated.
This is a learning experience for me, and believe it or not I am having a
good time, just looking for ideas on how I might be able to recover with
out doing a reload so I will start my preparation now and maybe you or
someone else might have some ideas on how moving my home folder
to the extra partition.
Right now I have copied home to the extra partition, I have kept the /home
directory intact. So now I will need to make an entry in the /etc/fstab
and maybe some other things too.

 
Answer #7    Answered On: Nov 30    

I have found that if you reinstall Ubuntu right on top of the existing one
without formating the partition, it is like a repair and will leave your
settings and stuff intact.

 
Answer #8    Answered On: Nov 30    

Ok that is what I might want to do but haven't see a way to do
that without going through the format section. Any help on
that would be appreciated.

 
Answer #9    Answered On: Nov 30    

You have to use the third option, custom install, I think it is called and just
skip the format option and go right to install, as I remember.

 
Answer #10    Answered On: Nov 30    

Out of curiosity since you dont appear to mention it, did you install the HP
print software from the ubuntu package manager?

 
Answer #11    Answered On: Nov 30    

I didn't install it that I remember but the next question is did I remove
it by mistake for some reason. So I will check Synaptic to see if I can
install it or do a reinstall.

 
Answer #12    Answered On: Nov 30    

That sounds like a drastic solution. If it were me, I'd open synaptic
and search for "print" to see what sort of printing related packages
there are to install.

 
Answer #13    Answered On: Nov 30    

I have not searched for just print, so I will do that next. I agree
that doing a reload may be a drastic measure but I am still
searching for other solutions for now. I will try just print as
a synaptic search too.

 
Answer #14    Answered On: Nov 30    

If 10.04 is a fresh install - reinstall and just start with a clean
setup. Once you have done that, post back with your printer make and
model, how you are connecting it and then Im sure someone will have some
answers for you then.

 
Answer #15    Answered On: Nov 30    

I just had another thought from a previous responder who
suggested just reloading with out reformatting the disk
section. If anyone can tell me how using the live disk so
far I haven't found it from the install option. Can you just
bypass that part of the install?
Also anyone, I have another partition labeled Home, and
under that I have copied my /home/Marty folder. Can I now
just issue the command in a terminal like:
sudo mount /home/Marty /home

Doesn't sound quite right to me but it has been 10 years or
more since I did any real Unix administration.

 
Answer #16    Answered On: Nov 30    

Well I am on the way to fixing the problem. On further playing around
I booted off the live CD and played with System on the panel, when right
clicking I now see the edit menus option, and when I did that on the live
cd I wrote down what was in properties on that and tried entering the same
on my booted version. It gave me the not found error but now I knew what
to search for so I next brought up Synaptic. I searched for
"System-config printer"
and found it and it wasn't installed. I marked it and installed it. Then
retried
the printer setup under System/Administration, I now have my usual setup
window pop up. Now I will try to connect to my window print server. I may
need to play with Samba to be able to see the printers but I have been down
that road before and I have a desktop using 9.10 all set up so I can use it
as a guide. But I think I remember that I need to make sure my network
workgroup is as it is at home.

 
Answer #17    Answered On: Nov 30    

Does this help?

Right-click on the Main Menu icon in the panel. On my system it brings
up a context menu which has an EDIT MENUS option. That has two panes. In
the left pane select Administration (at the bottom) and then in the
right pane you can see whether Printing is checked, and if necessary
edit its properties.

 
Answer #18    Answered On: Nov 30    

I have tried editing the Main Menu and it doesn't sound like
what you described if I am reading it right. Here is what I
did and see.
Under System I click Preferences and a panel comes up and
on that panel if I right click I have three choices, "Add this
launcher to panel" and "Add this launcher to desktop" and
"Entire menu" and under that menu is, "Add this as drawer
to panel" and "Add this as menu to panel".
If I just left click on "Main menu" I go right into the Main
menu itself. Once in Main menu I can make changes to
what shows up in "Applications and System" and then under
"System" is the two selections for "Preferences and Administration".
Under either I see check marks for what shows up in under
those items on the panel. Bringing up that doesn't have a
way that I can see to add the "Printer" back in to make it a
selectable item under "Administration".

 
Answer #19    Answered On: Nov 30    

As it happens, i have on several occasions noticed start menu items not being
installed when installing programs. Although most popup after a reboot.

 
Answer #20    Answered On: Nov 30    

I'm right-clicking on the menu icon itself, not any item on the menu and
nor the panel the icon sits on.

 
Didn't find what you were looking for? Find more on Still no print Or get search suggestion and latest updates.




Tagged: