Logo 
Search:

Unix / Linux / Ubuntu Forum

Ask Question   UnAnswered
Home » Forum » Unix / Linux / Ubuntu       RSS Feeds

Big trouble with removing gosa

  Date: Nov 27    Category: Unix / Linux / Ubuntu    Views: 524
  

I upgraded to Maverick Meerkat before the final release and tried to install
some programs. Among others, the programs needed for programming in FreeBASIC.
Nothing can be installed now due to some problem with removing package gosa. I
wanted to forcefully delete it but I cannot find it.
Here are some sample errors:
alexandru@alexandru-desktop:~$ sudo aptitude purge gosa
The following packages will be REMOVED:
gosa{ap}
0 packages upgraded, 0 newly installed, 1 to remove and 70 not upgraded.
Need to get 0B of archives. After unpacking 16.5MB will be freed.
Do you want to continue? [Y/n/?] Y
(Reading database ... 224702 files and directories currently installed.)
Removing gosa ...
dpkg: error processing gosa (--purge):
subprocess installed post-removal script returned error exit status 1
Errors were encountered while processing:
gosa
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:

alexandru@alexandru-desktop:~$

Please tell me what to do or where gosa is and how to remove it

Share: 

 

5 Answers Found

 
Answer #1    Answered On: Nov 27    

Have you tried:
dpkg --configure -a
or
apt-get -f install
?
You will need sudo if using Ubuntu or su if using another Debian distro. Try
the first one first as it relates more to your error message.

 
Answer #2    Answered On: Nov 27    

No results. Just those funny error messages. I copied everything from the
Terminal now.
What can be done ? In that time I would have done a new Ubuntu clean install
with deleting all the system folders and files except for what I have and
install without formatting.
What other alternatives are there except for reinstalling the system (done
really in 25 minutes) for the sake of one broken package that should not have
been installed after all and which interferes with the package manager ?
After a fresh install, there is 30-60 minutes of fun installing other
software, mainly from the repos.

 
Answer #3    Answered On: Nov 27    

If dpkg cannot be fixed using dpkg --configure -a then you would be as
well doing a clean install - as has been mentioned many times, any OS
upgrade is iffy at best and can be a pain in the neck !!

As you say, the time to do a clean install isn't that long compared to
the time already taken trying to fix things - at least you won't spend
a whole day trying to catch up like you would in Windows

 
Answer #4    Answered On: Nov 27    

I would try to remove all of the cached packages because rather than
download it defaults to using the cache.
sudo apt-get clean

then try to completely remove and re-install. It is worth a try. Whether it
is a time saver over a fresh installation is a separate question. You may
re-install and then have it re-occur.

 
Answer #5    Answered On: Nov 27    

I would try to remove all of the cached packages because rather than
download it defaults to using the cache.

 
Didn't find what you were looking for? Find more on Big trouble with removing gosa Or get search suggestion and latest updates.




Tagged: